Home > Ati Drivers > Ati Drivers 8.23 7 Intermodule Patch

Ati Drivers 8.23 7 Intermodule Patch

Please note that this is a trivial patch that only add pci ids to the module list. Closes: #508024 - This release fixes some crashes on starting/playing videos with players like kaffeine and mplayer. Import of Emil Karlson's ebuild from the x11 overlay. *ati-drivers-12.8 (19 Jan 2013) 19 Jan 2013; Rick Farina +ati-drivers-12.8.ebuild: readding 12.8, needed as dep for oclhashcat-*-bin *ati-drivers-13.1 (18 Jan 2013) Thanks to Jory Pratt and Bernd Steinhauser. *ati-drivers-8.443.1 (21 Dec 2007) 21 Dec 2007; +files/8.443.1/ati-powermode-opt-path-1.patch, +ati-drivers-8.443.1.ebuild: Version bump, thanks to Bernd Steinhauser and especially Jory Pratt. 01 Dec 2007; Jeff news

Haha, no.. - Adjust lintian overrides. * Add libatiuki to the fglrx-glx-ia32 package. -- Patrick Matthäi Wed, 17 Feb 2010 20:28:54 +0100 fglrx-driver (1:10-1-1) unstable; urgency=low * New upstream release. Thanks to ssuominen. 18 Aug 2009; Tomáš Chvátal ati-drivers-9.8.ebuild: Remove no-longer needed patches section. *ati-drivers-9.8 (18 Aug 2009) 18 Aug 2009; Tomáš Chvátal -ati-drivers-9.6.ebuild, -ati-drivers-9.7.ebuild, +ati-drivers-9.8.ebuild: Version bump. Closes: #516536 -- Patrick Matthäi Tue, 24 Feb 2009 18:39:19 +0200 fglrx-driver (1:9-1-2) unstable; urgency=low [ Patrick Matthäi ] * Implement debconf question for ACPI switching. * Backport it again Using the Vesa or xorg radeon drivers works without any crashes. imp source

Closes: #571272 -- Patrick Matthäi Thu, 25 Mar 2010 19:27:54 +0100 fglrx-driver (1:10-3~prerelease-2) unstable; urgency=low * Add workaround, so that the i386 package, does not depend on a amd64 only Closes: #613829 -- Patrick Matthäi Thu, 17 Feb 2011 18:11:37 +0100 fglrx-driver (1:11-1-3) unstable; urgency=low * Bump dependency to xorg-video-abi-8.0. Highlights from the release notes: - Attempting to resume from system suspension no longer results in the system failing to respond. - Kernel module compile issues with the stock 2.6.13 and

Use the DisplaySize parameter within your monitor's configuration. Change SRC_URI for the XVBA SDK, bug #453192. Replace (or comment-out) Load "extmod" with SubSection "extmod" Option "omit xfree86-dga" EndSubSection Freeze while using OpenGL Apps Some OpenGL applications such as screensavers or games (SecondLife) cause freezes. Closes: #614705 * Add patch 07-2.6.39-support.diff to build with Linux 2.6.39.

No more binary hacking needed. X server gives an error "Invalid video BIOS signature" after installing fglrx In cases where you get an X error containing the following lines: fglrx(0): Invalid video BIOS signature! Closes: #586797 * Start atieventsd before $x-display-manager. https://lists.debian.org/debian-user/2011/06/msg01371.html Problem: graphical glitches with mplayer, programs like xine and totem might not start up at all. 8.35 doesn't seem to be affected Floating Point Exception with various X apps When the

So as usual, ATI doesn't support final kernel when they are released since maybe 3 weeks ! No longer needed. punx120 View Public Profile Find More Posts by punx120 punx120's System Specs Apr 12, 2006, 06:19 PM #20 KanoTheMaster Radeon R300 Join Date: Jun 2005 Posts: 191 Maybe just Make sure that you have proper drivers for your motherboard loaded before fglrx: (gentoo: /etc/modules.autoload.d/kernel-2.6): intel-agp fglrx A common problem seems to be mistakenly using ATI Chipset drivers instead of Intel.

No hardware acceleration Acceleration lost after driver update If you lose hardware acceleration after a driver update this can be caused by an old fglrx kernel module being loaded. Closes: #520480 * Simplify describe in README.Debian how to build the fglrx module and enabling 3d acceleration support. This has been seen to happen using fglrx without the kernel module installed (in 2D mode) and additionally on external displays or multiple X servers. Closes: #533750 - The map error should be gone away now.

Previous by thread: Re: ATI driver Next by thread: Re: ATI driver Index(es): Date Thread Problems with fglrx From ThinkWiki Jump to: navigation, search This page discusses issues with the ATI http://advianetwork.com/ati-drivers/ati-drivers-7-11.html There are two possible workarounds for this bug: 1/ Open the Catalyst Control Center and force the anti-aliasing to at least 2x for all applications. Per bug #275427. *ati-drivers-9.6 (25 Jun 2009) 25 Jun 2009; Tomáš Chvátal +files/kernel/2.6.29.patch, +files/kernel/2.6.30-enable_msi.patch, +files/kernel/2.6.30-irqreturn_t.patch, +files/kernel/2.6.30-rt_compat.patch, +files/kernel/2.6.30-tlb_flush.patch, +ati-drivers-9.6.ebuild: Add new version of ati drivers (9.6). All you have to do now is to delete any versions of the module (look at the filedate) but the most current one.

Closes: #514061 * Refresh lintian overrides (drop some more and add one new). * Also add ia32-apt-get support for fglrx-driver, which is also experimental and as broken as ia32-fglrx-glx, because of a line like this: libGL.so.1 => /usr/lib/opengl/xorg-x11/lib/libGL.so.1 (0x400a8000) you will also need to relink libGl.so.1.2: # cd /usr/lib/opengl/xorg-x11/lib/ # mv libGL.so.1.2 libGL.so.1.2_backup # ln -s /usr/lib/libGL.so.1.2 libGL.so.1.2 After another restart of Go to /lib/modules// and type # grep fglrx modules.dep. http://advianetwork.com/ati-drivers/ati-drivers-8-27.html parameter, no special script, no vbetool.

Video accelerated playback for Avivo cards is enabled by default. Closes: #506000 - It should build fine now with Linux 2.6.27. display::0.0 screen: 0 OpenGL vendor string: ATI Technologies Inc.

See bug #526602. *ati-drivers-14.9 (23 Oct 2014) 23 Oct 2014; Chí-Thanh Christopher Nguyễn +ati-drivers-14.9.ebuild, +files/fix-the-linux-3.17-no_hotplug-error.patch: Version bump.

Env file and blocker against nvidia are no longer needed *ati-drivers-12.1 (30 Jan 2012) 30 Jan 2012; Chí-Thanh Christopher Nguyễn +ati-drivers-12.1.ebuild: Version bump. My friends new computer was a GeForce and my coworker new card will be a GeForce. Closes: #585433 [ Michael Gilbert ] * Build modules for all installed kernel packages rather than only for the currently active/running kernel. -- Patrick Matthäi Sat, 28 Aug 2010 09:05:52 FInally, you modify the debian control file to correct the dependency but after all these efforts, Xorg doesn't start.

Daniel Leidert, the manpages maintainer, says Debian's docbook stuff is hopelessly outdated, so I'm using precompiled man pages provided by Daniel instead of building them from the DocBook sources. Recommending the package in fglrx-driver. Thanks lintian. * Remove odd debian/TODO. * Fit debian/README.hacking to the up to date and easy orig-source-target to build the original tarball. * Change to dpatch instead of a self-hackish one http://advianetwork.com/ati-drivers/ati-drivers-8-27-10-r1.html This issue was known to occur with Radeon X1K products. - Running aticonfig--dtop=(horizontal|vertical) no longer results in clone mode being activated when attempting to enable big desktop mode. - Switching between

Wow even XV accel using AVIVO thats an unexpected treat . __________________ jec0s View Public Profile Find More Posts by jec0s jec0s's System Specs Apr 12, 2006, 03:27 PM Remove old. Closes: #557316 * Rediff hunky 01-CONFIG_X86_XEN patch. HTTP request sent, awaiting response... 404 Not Found 22:57:57 ERROR 404: Not Found.

Tomorrow: step 5. - -- Best regards, Panayiotis Karabassis -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.11 (GNU/Linux) Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/ iQEcBAEBAgAGBQJN+P6DAAoJEN7RcJcJCZJi/W4IAIm3PtrKJ83RDJ9oD71GGUGt 4+gQeEMMtk2mcPJU/UWoKcRQHhwluZ2FwAx1Dn3PWP+Ut/SWjd+6LjZLonHOeW/O V+SkBYKD3JG+wwGF/DNEBlKSouv90rt2/6VgBWRzCZrNlOrMAGyrWcN1JoQPf2/D 66FynRXKejB0g7rRX4mkHM/CkhvT+WkN41zihjOddAQSzKS2Osxn/XbefflZbp77 xyRdchApRNVH4taAfHPiPH2qUXOYzVNL5b91Boywa76x7cFQgXNanBK7oDxNwd6g SL4wJ23d1nnEFV1nqfmBkIrgHu64lyZXK9PB5/JVsyT0vTEDW9vMd4bPxh9AdB8= =e9lS -----END Closes: #543384 * Sync uploaders of the control template with the original one. * Remove unused orphaned-diversion lintian overrides from fglrx-glx. -- Patrick Matthäi Thu, 27 Aug 2009 18:40:15 +0200 It works with the R300 / FireGL T2 series as found on the T43p extremely well. Change libOpenCL installation path, bug #391131.

rizrage3d View Public Profile Find More Posts by rizrage3d rizrage3d's System Specs Apr 12, 2006, 05:57 PM #18 KanoTheMaster Radeon R300 Join Date: Jun 2005 Posts: 191 8.23.7 vs. fglrx 8.37.6 For kernel 2.6.22 you need this patch from a Phoronix thread. dataangel View Public Profile Find More Posts by dataangel dataangel's System Specs Apr 12, 2006, 01:10 PM #3 phoronix Radeon R200 Join Date: Jan 2006 Posts: 58 Phoronix has Composite Support ATI, as of fglrx 8.42.3 added composite windowing (alpha channel), enabling hardware accelerated translucent windows (primarily for 'eye candy.') This has not been tested yet, and reports will be

connected. These include: Quake 3: Texture corruption is no longer noticed when playing the game on systems containing an ATI Radeon 8x00, Radeon 9000, Radeon 9100, Radeon 9200, or Radeon 9250 product R50p ??? ??? 8.19.10 swsusp yes T43p Debian sid 2.6.14 8.19.10 Suspend to RAM yes without vbetool or UseDummyXServer, those two break the resume process here, with DRI enabled T43p Debian Closes: #510496 * Add README.Debian with backporting informations. * Also describe in README.Debian, that "DefaultDepth 24" in xorg.conf is needed for fglrx.

I've just downloaded Kororaa Xgl Demo Live CD (Version 0.2) and hope i get a chance to test it tomorrow. (but it uses 8.23.7 driver) these are still not fixed: Quote: A binary hack solves the Problem (rage3d.com Forum Entry). Howard. 17 Oct 2008; Jeff Gardner ati-drivers-8.542.ebuild: Fix malformed header *ati-drivers-8.542 (17 Oct 2008) 17 Oct 2008; Jeff Gardner +ati-drivers-8.542.ebuild: Latest version, thanks to Josh Saddler, closing bug #239248. As of version 8.37.6, this issue is solved.

Page 1 of 4 1 234 > Thread Tools Display Modes Apr 12, 2006, 11:48 AM #1 Advertisement (Guests Only) Login or Register to remove this ad mooninite Radeon The only workaround is currently to compile a custom kernel with SLAB support! Then, if you extract it by hand and if you build a debian package, it can't be installed because of a dependency problem. Thanks.