Home > Ati Rage > Ati Rage Mobility P M Agp 2x Linux Driver

Ati Rage Mobility P M Agp 2x Linux Driver

I hope you didn't have to actually recompile the kernel :( bump! I have the gcc 4.0 compiler. Laptop: LG LM70 Express Kernel: 3.14.2-1-ARCH ATI Radeon X850 XT Yes Yes Yes Edgy & Dapper if X server does not start with driver "Ati" (first boot) change it to "vesa" and then follow the instructions on http://advianetwork.com/ati-rage/ati-rage-mobility-m4-linux-driver.html

Package fglrx-control is recommended. I had a look at the "Alternate Operating System Driver Support Chart", http://ati.amd.com/developer/altoschart.pdf, and here's what it says: 3D support is not available for RAGE PRO derivatives, including MOBILITY P/M/M1 under Help please for old poor laptop people who wants celestia!!! usr:~$ bash install.sh thanks alots :D gregory_cookyNovember 16th, 2006, 12:42 AMHello I did everything, and it works (Thank You VeRy MuCh), I mean direct rendering, but what does "libGL warning: 3D

For example, some of the 3D-effect screensavers and music visualisations included in Ubuntu applications really ought to be quicker than they are, and I can't believe it's the OS or the I think we will have to use the 'correct' version of the driver. :( But, don't really know how to find that... Reply With Quote 05-11-200810:30 PM #2 ghoti View Profile View Forum Posts Private Message View Blog Entries Visit Homepage View Articles Karmic Sangoma Join Date Jan 2005 Location Hotel California

Posted by lane329 on 21 Mar 2010 13:25 Hi, its an old CPX Like 0 Reply You have posted to a forum that requires a moderator to approve posts before they Reply With Quote 20-11-200811:04 PM #9 fskmh View Profile View Forum Posts Private Message View Blog Entries View Articles Grandmaster Join Date Feb 2007 Location ${HOME} Posts 1,180 The vesa Registered: 2012-02-26 Posts: 136 [SOLVED] Swap on video ram ATI Rage Mobility P/M AGP 2x I'm just following this instructions:https://wiki.archlinux.org/index.php/Swap_on_video_ramBut, i'm not sure if its possible for this old card:01:00.0 VGA IIRC the Rage Mobility-M1 is based on a Mach64 chip (driver: mach64) which is not the same as a Rage128 (driver: r128) so they don't use the same driver. __________________ Software:

Stop. Password Forgot Password? The installer setup file may include a purely optional advertising offer which you are free to decline. http://www.techsupportforum.com/forums/f24/ati-rage-mobility-p-m-agp-2x-drivers-437335.html ATI Mobility FireGL 9000 RV250lf Yes Yes Yes ATI Rage Mobility P/M AGP 2x Yes Yes Yes TV-Out doesn't work!

then restart X, I only got blank screen and lock-up of sysytem, can only resort to restart button of the PC to escape the idle state... Tech Support Forum Security Center Virus/Trojan/Spyware Help General Computer Security Computer Security News Microsoft Support BSOD, Crashes And Hangs Windows 10 Support Windows 8, 8.1 Support Windows 7, Vista Support Windows It is working so perhaps for your use cases you do stay within that, but, someday your process' will be randomly killed and having swap will decrease that likely-hood quite a Thank you for this good walkthrough.:D fruchtschwertAugust 6th, 2006, 11:45 AMHallo everyone, I have a Sony Vaio Laptop with a ATI Rage Mobility 8 MB graphics chip and Ubuntu Dapper running.

All the links I've found on google are several years old, and refer to drivers that are doubtless either obselete or included in my distro (Xubuntu) and so I'm using already. https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsAti The GPU is 3D accelerated also. If you want x to start w/ gnome, create a file named ".xinitrc" in your home dir...then edit it like this: xterm & gnome-session this will start gnome when you start Based on info.

I did this in Dapper upgraded (And June 1st is in 13 minutes!) David MarrsJune 3rd, 2006, 12:51 PMUnfortunately, direct accelleration has stopped working for me now and I can't get useful reference I have no idea how to fix this ... My video card only has 8MB, and a depth of 24 required 9600 KB of videor memory. Why are there people, having no problems at all ?

Even then you don't have to have it. But the installer seems not to determine the right installaltion directories. The script reports the same error as in Dapper: The DRI drivers can not be installed without the latest kernel modules. my review here AriccanflyMarch 17th, 2006, 06:34 PMI've been following this post for a while.

make -C /lib/modules/2.6.19-gentoo-r1/source SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules make[2]: Entering directory `/usr/src/linux-2.6.19-gentoo-r1' CC [M] /usr/src/mach64-20060403-linux.i386/drm/linux-core/drm_auth.o In file included from /usr/src/mach64-20060403-linux.i386/drm/linux-core/drm_auth.c:36: /usr/src/mach64-20060403-linux.i386/drm/linux-core/drmP.h:44:26: error: linux/config.h: No such file or directory make[3]: *** [/usr/src/mach64-20060403-linux.i386/drm/linux-core/drm_auth.o] Error 1 thanks stateq2December 5th, 2004, 07:09 PMI try to use your method of getting DRI to work with my mach64 based Rage 3d chip. Bern View Public Profile Find More Posts by Bern Bern's System Specs Extra Info125 Oct 30, 2007, 07:20 AM #7 jadebo Newbie Join Date: Oct 2007 Posts: 1 Since

The module compiles/loads allright, but glxinfo still shows disabled.

Seems that 3d support for old ATI rage (very common on old laptops) is break in dapper. Also my Xorg.0.log says direct rendering enabled but that doesn't really help me without visible screen. The script will use the following Xorg directories: Xorg Dir : /usr/X11R6 Xorg Modules Dir : /usr/X11R6/lib/modules Xorg Library Dir : /usr/X11R6/lib If this is correct press ENTER, press C to my wife will kill me if I destroy the computer again.

ATI Rage 128 PRO TMDS ATI Yes Yes Yes v5.04 (Hoary) Cursor become black when 3D rendering is active. from the lines bellow I'm thinking that Mach64 chip is not actually supported by the driver (since it sais only Rage 128 & Radeon). Gabriele gigahzJuly 17th, 2006, 08:03 PMupdate 03-25-06 I have been struggling w/ this for the past two weeks....and I finally got 3d acceleration to work w/ my ati rage mobility. ... http://advianetwork.com/ati-rage/ati-rage-mobility-m3-linux-driver.html I'm using kernel 2.6.8.1-3-386.

Last edited by headkase (2012-06-22 06:54:37) We all make choices, but in the end, our choices make us. Offline #12 2012-06-22 15:59:43 ismaelvc Member From: México, D.F. here's my xorg.conf minus the comments Section "Files" FontPath "unix/:7100" # local font server # if the local font server has problems, we can fall back on these FontPath "/usr/lib/X11/fonts/misc" FontPath Release Date: 10/23/2001 Version: M6.12.40-T01, A00 Download Type: Driver File Format: Hard Drive File Size: 5 MB Other Formats Like 0 Reply You have posted to a forum that requires

reh4cMarch 11th, 2006, 11:20 AMAlso useful link is you have some problems with DRI (AGP or DRM) is: [http://dri.freedesktop.org/wiki/DriTroubleshooting] Hope that this helps you with mach64 problems \\:D/ Thanks again for if you have problems after reboot: a.) check if module is listed in "/etc/modules" cat /etc/modules | grep "mach64" b.) if not, add it sudo echo "mach64" >> /etc/modules if you Tried with 15 bits but DRI is supported only for 16 bit and 32 bit as found in the Xorg logs. See the dri.log file for information on what went wrong.

Arch Linux HomePackagesForumsWikiBugsSecurityAURDownload Index Rules Search Register Login You are not logged in. Thnx. Using common-20060403-linux.i386.tar and mach64-20060403-linux.i386.tar It was already 16 bit. Chromium and gl screensaver (e.g. "AntSpotlight") runs for 0-to-2 seconds and then the system hangs (I need to power off).

Ok, how did you get around that error? On some manufacturer's cards (I think Abit, a red card) openGL doesn't work, gdb says crash happens in the driver. Actually it runs much worse after that. mr_spuck View Public Profile Find More Posts by mr_spuck mr_spuck's System Specs Oct 25, 2007, 01:55 PM #5 JOPS Sysadm. & developer Join Date: Sep 2002 Location: Stockholm, Sweden

First I`ve got the problem when installing the dri : I got this message Syntax error: Bad fd number, but after browse the web for a while I found the clue Did anyone ever work this out? The commands after the first cp didn't seem to do much, but as you promised, nothing seems to be broken. There are no drivers on ATI's site for that card that I can see, the legacy drivers are only windows, and the linux drivers listed don't seem to include this thing.